lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Rowe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-7446) Fix back-compat version check in addVersion helper script
Date Tue, 13 Sep 2016 15:22:20 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-7446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15487497#comment-15487497
] 

Steve Rowe commented on LUCENE-7446:
------------------------------------

Using the script with my patch applied, following are the versions I successfully added on
the given branches ("Context" refers to the three contexts in which {{addVersion.py}} is used
- see my previous comment):

||Context||Version added||Branch||
|1|5.5.5|branch_5_5|
|1|6.2.2|branch_6_2|
|1|6.4.0|branch_6x|
|1|8.0.0|master|
|2|6.2.2|branch_6x|
|2|6.2.2|master|
|3|4.10.5|branch_6x|
|3|5.5.4|master|

Committing shortly.

> Fix back-compat version check in addVersion helper script
> ---------------------------------------------------------
>
>                 Key: LUCENE-7446
>                 URL: https://issues.apache.org/jira/browse/LUCENE-7446
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Anshum Gupta
>            Assignee: Anshum Gupta
>            Priority: Minor
>         Attachments: LUCENE-7446.patch, LUCENE-7446.patch
>
>
> As part of the 5.5.3 post-release process, I was trying to bump up the number to 5.5.4
on the release branch but ran into the following error:
> {code}
> Traceback (most recent call last):
>   File "dev-tools/scripts/addVersion.py", line 246, in <module>
>     main()
>   File "dev-tools/scripts/addVersion.py", line 221, in main
>     if current_version.is_back_compat_with(c.version):
>   File "/Users/anshumgupta/workspace/lucene-solr/dev-tools/scripts/scriptutil.py", line
75, in is_back_compat_with
>     raise Exception('Back compat check disallowed for newer version: %s < %s' % (self,
other))
> Exception: Back compat check disallowed for newer version: 5.5.3 < 5.5.4
> {code}
> I think the check is wrong and should be reversed. I'll post a patch that I used to work
around this but would be good to have more eyes on this before I commit this.
> [~steve_rowe]: Can you take a look at the patch as I guess you added this recently.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message