lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <>
Subject [jira] [Commented] (LUCENE-7042) more cleanup for Point encodings
Date Mon, 22 Feb 2016 22:51:18 GMT


Michael McCandless commented on LUCENE-7042:

+1, thanks [~rcmuir]!

> more cleanup for Point encodings
> --------------------------------
>                 Key: LUCENE-7042
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Robert Muir
>         Attachments: LUCENE-7042.patch
> Followup of LUCENE-7039.
> I started consolidating encode/decode functions into XYZField, but its still pretty messy.
Specifically, duplicated code because indexer wants packed byte[] and queries want byte[][]
and so on.
> We can do a bit more cleanup: by defining everything in terms of encodeDimension() and
decodeDimension(). This way, the logic is only in one place. 
> Also the new NumericUtils methods here are confusing I think. Its scary how they take
a "dimensional index" when parsing from a byte[]. I think they should just take 'offset' and
not try to be fancy, its easier to understand.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message