lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCandless (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-6917) Deprecate and rename NumericField/RangeQuery to LegacyNumeric
Date Mon, 14 Dec 2015 11:06:46 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-6917?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15055836#comment-15055836
] 

Michael McCandless commented on LUCENE-6917:
--------------------------------------------

Hi [~ichattopadhyaya], I'm not sure why you are hitting that ... but can you email the dev
list instead ({{dev@lucene.apache.org}})?

> Deprecate and rename NumericField/RangeQuery to LegacyNumeric
> -------------------------------------------------------------
>
>                 Key: LUCENE-6917
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6917
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 6.0
>
>         Attachments: LUCENE-6917-broken-javadocs.patch, LUCENE-6917.patch, LUCENE-6917.patch,
LUCENE-6917.patch
>
>
> DimensionalValues seems to be better across the board (indexing time, indexing size,
search-speed, search-time heap required) than NumericField, at least in my testing so far.
> I think for 6.0 we should move {{IntField}}, {{LongField}}, {{FloatField}}, {{DoubleField}}
and {{NumericRangeQuery}} to {{backward-codecs}}, and rename with {{Legacy}} prefix?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message