lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrien Grand (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LUCENE-6634) PKIndexSplitter should take queries, not filters
Date Mon, 29 Jun 2015 17:48:04 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-6634?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Adrien Grand updated LUCENE-6634:
---------------------------------
    Attachment: LUCENE-6634.patch

I changed the name to preserveWeight when it becomes a Weight. However I kept preserveFilter
when it is still a Query as I think it nicely conveys the fact that scores won't be used?

> PKIndexSplitter should take queries, not filters
> ------------------------------------------------
>
>                 Key: LUCENE-6634
>                 URL: https://issues.apache.org/jira/browse/LUCENE-6634
>             Project: Lucene - Core
>          Issue Type: Task
>            Reporter: Adrien Grand
>            Assignee: Adrien Grand
>            Priority: Minor
>             Fix For: 5.3
>
>         Attachments: LUCENE-6634.patch, LUCENE-6634.patch
>
>
> We could make PKIndexSplitter work on the Query API instead of Filter. This way lucene/misc
would not depend on oal.search.Filter anymore.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message