lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Noble Paul (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SOLR-7668) Port-base rule for shard placement causes NPE
Date Mon, 15 Jun 2015 14:48:00 GMT

    [ https://issues.apache.org/jira/browse/SOLR-7668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14586131#comment-14586131
] 

Noble Paul edited comment on SOLR-7668 at 6/15/15 2:47 PM:
-----------------------------------------------------------

It was not committed as is . I had to edit some of it. That is why I used a comma instead
of 'via'


was (Author: noble.paul):
It was committed as is . I had to edit some of it. That is why I used a comma instead of 'via'

> Port-base rule for shard placement causes NPE
> ---------------------------------------------
>
>                 Key: SOLR-7668
>                 URL: https://issues.apache.org/jira/browse/SOLR-7668
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 5.2
>            Reporter: Adam McElwee
>            Assignee: Noble Paul
>            Priority: Minor
>         Attachments: SOLR-7668.patch, SOLR-7668.patch
>
>
> I was setting up some rule-based collections, and I hit an NPE whenever I try to include
a port-based rule. It looks like the implementation was started, but not completed for ports.
Patch coming in just a moment.
> I included a test, and I have no problems getting the test to pass when run by itself.
However, when I run it w/ the other tests in RulesTest, it fails because of some ZK errors,
but I often have those issues when running any of the distrib tests.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message