lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timothy Potter (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SOLR-7487) check-example-lucene-match-version is looking in the wrong place - luceneMatchVersion incorrect in 5.1 sample configs
Date Thu, 30 Apr 2015 17:27:07 GMT

     [ https://issues.apache.org/jira/browse/SOLR-7487?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Timothy Potter updated SOLR-7487:
---------------------------------
    Attachment: SOLR-7487.patch

Updated patch includes change to addVersion.py to walk the correct directory: solr/server/solr/configsets
(was solr/example)

> check-example-lucene-match-version is looking in the wrong place - luceneMatchVersion
incorrect in 5.1 sample configs
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-7487
>                 URL: https://issues.apache.org/jira/browse/SOLR-7487
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 5.1
>            Reporter: Hoss Man
>            Assignee: Timothy Potter
>            Priority: Blocker
>             Fix For: 5.2
>
>         Attachments: SOLR-7487.patch, SOLR-7487.patch
>
>
> As noted by Scott Dawson on the mailing list, the luceneMatchVersion in the 5.1 sample
configs all still lists "5.0.0".
> The root cause seems to be because the check-example-lucene-match-version task in solr/build.xml
is looking in the wrong place -- it's still scaning for instances of luceneMatchVersion in
the {{example}} directory instead of the {{server/solr/configset}}
> TODO:
> * fix the luceneMatchVersion value in all sample configsets on 5x
> * update the check to look in the correct directory
> * update the check to fail to be smarter know that we have a more predictable directory
structure
> ** fail if no subdirs found
> ** fail if any subdir doesn't contain conf/solrconfig.xml
> ** fail if any conf/solrconfig.xml doesn't contain a luceneMatchVersion
> ** fail if any luceneMatchVersion doesn't have the expected value



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message