lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charlie Orford <char...@charlie.is>
Subject Re: Moving to Java 7 on debian breaks ICU Normalizer2 on Solr 4.7.2 and Solr 4.10.1
Date Thu, 09 Oct 2014 16:20:48 GMT
Thanks Shawn you're a genius! Changed the sharedLib path to a 
non-existent directory and Solr is now happily running on Java 7.

Is this a bug with Solr or was I doing it wrong? My solr.xml looked like 
this before:

<?xml version="1.0" encoding="UTF-8" ?>
<!--
  All (relative) paths are relative to the installation path

   persistent: Save changes made via the API to this file
   sharedLib: path to a lib directory that will be shared across all 
cores (optional)
-->
<solr>
     <str name="coreRootDirectory">/srv/solr/4.7</str>
     <str name="sharedLib">lib</str>
     <int name="coreLoadThreads">4</int>
</solr>


Replacing "lib" with "li2b" (which doesn't exist) solved the problem. 
Here's the log: http://hastebin.com/hucikamora.avrasm (the jars under 
lib/ are still being loaded but only the once now).

Charlie

On 09/10/2014 16:49, Shawn Heisey wrote:
> On 10/9/2014 5:57 AM, Charlie Orford wrote:
>> Here are the startup logs from Solr (first one shows running under
>> Java 6 and working, second one is the very same installation runing
>> under Java 7 and failing):
>>
>> http://hastebin.com/yapuqonide.vhdl
>> http://hastebin.com/edigeduset.pas
> This looks like the problem I described here:
>
> https://issues.apache.org/jira/browse/SOLR-4852
>
> I see that your jars are loaded twice, which seems to be the root of the
> problem.  I never tried this under Java 6, I had already upgraded to
> Java 7 by then.  I bet if you remove the sharedLib setting from
> solr.xml, it'll start working correctly.
>
> Thanks,
> Shawn
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message