lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-5956) Add runnable index upgrader
Date Tue, 16 Sep 2014 17:56:33 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-5956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14135828#comment-14135828
] 

Robert Muir commented on LUCENE-5956:
-------------------------------------

Hi, a few questions:

* should it really be separate from the current 'backwards-codecs' module? Not saying if its
right or wrong, but thats where the tests for the upgrader are.
if they were combined, we could package it nicely and have "simpler" back compat to the user.

* how valuable is it to support older than N-1 indexes, when the analysis chains used to create
them have now changed? 

* how will SPI etc work here, will the older versions somehow have their own SPI lists in
different classloader or something?

> Add runnable index upgrader
> ---------------------------
>
>                 Key: LUCENE-5956
>                 URL: https://issues.apache.org/jira/browse/LUCENE-5956
>             Project: Lucene - Core
>          Issue Type: New Feature
>            Reporter: Ryan Ernst
>
> As a spinoff from discussion in LUCENE-5940, I'd like to add a new module "lucene-upgrader",
move {{IndexUpgrader}} to this, and add embed older versions of lucene (just enough to upgrade
indexes) in the built version of the module's jar.  This would be runnable from the command
line with something like:
> {{java -jar lucene-upgrader-4.11.0.jar /path/to/index}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message