lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] [Updated] (LUCENE-5493) Rename Sorter, NumericDocValuesSorter, and fix javadocs
Date Thu, 06 Mar 2014 17:28:43 GMT


Robert Muir updated LUCENE-5493:

    Attachment: LUCENE-5493.patch

Here is a patch for review. The public API is much simpler and I think it makes the SortingMP
a lot more flexible and easier to use.

> Rename Sorter, NumericDocValuesSorter, and fix javadocs
> -------------------------------------------------------
>                 Key: LUCENE-5493
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>            Assignee: Robert Muir
>         Attachments: LUCENE-5493-poc.patch, LUCENE-5493.patch
> Its not clear to users that these are for this super-expert thing of pre-sorting the
index. From the names and documentation they think they should use them instead of Sort/SortField.
> These need to be renamed or, even better, the API fixed so they aren't public classes.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message