lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shawn Heisey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-5613) Upgrade Apache Commons Codec to version 1.9 in order to improve performance of BeiderMorseFilter
Date Tue, 07 Jan 2014 16:31:53 GMT

    [ https://issues.apache.org/jira/browse/SOLR-5613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13864364#comment-13864364
] 

Shawn Heisey commented on SOLR-5613:
------------------------------------

I upgraded commons-codec to 1.9 on an up-to-date branch_4x checkout and found that all tests
(both Lucene and Solr) passed.  This was on a linux machine.  I wasn't too surprised by this.
 I think we can accommodate this request easily.

Just for giggles, I went even further and upgraded all commons.apache.org components to the
newest versions I could find via ivy.  All tests *still* passed.  This was on a Windows 8
machine.  With so many upgrades, I was really surprised it passed.

{code}
Index: lucene/ivy-versions.properties
===================================================================
--- lucene/ivy-versions.properties      (revision 1555313)
+++ lucene/ivy-versions.properties      (working copy)
@@ -19,16 +19,16 @@
 /com.ibm.icu/icu4j = 52.1
 /com.spatial4j/spatial4j = 0.3
 /com.sun.jersey/jersey-core = 1.16
-/commons-beanutils/commons-beanutils = 1.7.0
+/commons-beanutils/commons-beanutils = 1.9.0
 /commons-cli/commons-cli = 1.2
-/commons-codec/commons-codec = 1.7
+/commons-codec/commons-codec = 1.9
 /commons-collections/commons-collections = 3.2.1
-/commons-configuration/commons-configuration = 1.6
-/commons-digester/commons-digester = 2.0
-/commons-fileupload/commons-fileupload = 1.2.1
-/commons-io/commons-io = 2.1
+/commons-configuration/commons-configuration = 1.10
+/commons-digester/commons-digester = 2.1
+/commons-fileupload/commons-fileupload = 1.3
+/commons-io/commons-io = 2.4
 /commons-lang/commons-lang = 2.6
-/commons-logging/commons-logging = 1.1.1
+/commons-logging/commons-logging = 1.1.3
 /de.l3s.boilerpipe/boilerpipe = 1.1.0
 /dom4j/dom4j = 1.6.1
 /edu.ucar/netcdf = 4.2-min
{code}

I'm not advocating that we upgrade all the components at once, but it looks like we can indeed
upgrade them all eventually.  I only ran the basic tests, so additional tests (nightly, weekly,
etc) need to be done.


> Upgrade Apache Commons Codec to version 1.9 in order to improve performance of BeiderMorseFilter
> ------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-5613
>                 URL: https://issues.apache.org/jira/browse/SOLR-5613
>             Project: Solr
>          Issue Type: Improvement
>          Components: Rules, Schema and Analysis, search
>    Affects Versions: 3.6, 3.6.1, 3.6.2, 4.0, 4.1, 4.2, 4.2.1, 4.3, 4.3.1, 4.4, 4.5, 4.5.1,
4.6
>            Reporter: Thomas Champagne
>              Labels: codec, commons, commons-codec, phonetic, search
>
> In version 1.9 of commons-codec project, there are a lot of optimizations in the Beider
Morse encoder. This is used by the BeiderMorseFilter in Solr. 
> Do you think it is possible to upgrade this dependency ?



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message