lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: FYI: localhost vs 127.0.0.1 in networking-related tests
Date Sat, 08 Jun 2013 13:03:15 GMT
I think this is absolutely related. But i did a quick search for
"localhost" in the source tree and found occurrences in src/ and test/
related code... if the server is binding ONLY to 127.0.0.1, but the client
is trying to connect to "localhost", it could be causing issues with those
tests on certain configurations (at least OS X + java6)

On Sat, Jun 8, 2013 at 8:57 AM, Erick Erickson <erickerickson@gmail.com>wrote:

> Dear Lord that's obscure! If I remember right, Uwe advocated using
> 127.0.0.1
> at one point, is this related?
>
> Anyway, I'm glad you were able to track this down!
>
> Erick
>
> On Sat, Jun 8, 2013 at 8:49 AM, Robert Muir <rcmuir@gmail.com> wrote:
> > Hello,
> >
> > As you know, the jetty test in lucene's replicator module would fail in
> > non-reproducible ways, only on Mac OS X, and only on java6. Finally we
> got
> > to the bottom of this:
> > https://issues.apache.org/jira/browse/LUCENE-5037
> >
> > The basic problem is: the server would start on 127.0.0.1, but the client
> > would connect to localhost. At least this one configuration (OSX + java6)
> > behaves wierd on a dual-stack ipv4/ipv6 system, it seems to round-robin
> thru
> > the 3 entries for localhost in /etc/hosts (127.0.0.1, ::1, and link-local
> > ipv6). This means the test would fail if the resolver picked an ipv6 one.
> >
> > So the fix was to just use 127.0.0.1 for both server and client in the
> test.
> >
> > I wonder if the same bug impacts other tests (e.g. solr jetty tests)
> using
> > jetty.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>
>

Mime
View raw message