lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LUCENE-2101) Default Stopwords should use specific Version in CharArraySet construtor
Date Thu, 09 May 2013 23:06:14 GMT

     [ https://issues.apache.org/jira/browse/LUCENE-2101?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Uwe Schindler updated LUCENE-2101:
----------------------------------

    Fix Version/s:     (was: 4.3)
                   4.4
    
> Default Stopwords should use specific Version in CharArraySet construtor
> ------------------------------------------------------------------------
>
>                 Key: LUCENE-2101
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2101
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Simon Willnauer
>            Priority: Minor
>             Fix For: 4.4
>
>
> [LUCENE-2094] added a version to the constructor of CharArraySet. The default sets in
*Analyzer uses Version.LUCENE_CURRENT which currently does not do any harm. Yet, in the future
changes to CharArraySet depending on the version could potentially cause index corruption
if those default version are not changed. To make sure such a corruption can not happen the
default sets should use a specific Version (Version.LUCENE_31)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message