lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Commit Tag Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-4759) Cleanup Velocity Templates
Date Mon, 29 Apr 2013 07:10:21 GMT

    [ https://issues.apache.org/jira/browse/SOLR-4759?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13644316#comment-13644316
] 

Commit Tag Bot commented on SOLR-4759:
--------------------------------------

[branch_4x commit] uschindler
http://svn.apache.org/viewvc?view=revision&revision=1476908

Merged revision(s) 1476907 from lucene/dev/trunk:
SOLR-4759: Add missing svn:eol-style properties
                
> Cleanup Velocity Templates
> --------------------------
>
>                 Key: SOLR-4759
>                 URL: https://issues.apache.org/jira/browse/SOLR-4759
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.2
>            Reporter: Mark Bennett
>            Assignee: Erik Hatcher
>             Fix For: 5.0, 4.4
>
>         Attachments: SOLR-4759.patch, velocity-SOLR-4759.zip
>
>
> Cleanup to Velocity templates shipped under solr/example/solr/collection1/conf/velocity
> * Add README.txt file with complete file list
> * Add comments to all files
> * Add indenting where feasible, fixed indenting in other places.  I don't believe I've
broken anything that required precise indenting.
> * Make file naming consistent.  We had this_that, thisThat and this-that
>   Changed all to this_that, though also considered this-that.
> * Modularize some files
> * Included a hit_plain.vm example, though not active by default.
> * Rewrote city/lon/lat selector to work from a hash, though doesn't change the behavior.
> * CSS changes, primarily to make top "tabs" actually look like Tabs (primitive CSS, but
at least conveys the idea)
> As far as I know this doesn't change any behavior of the system, nor does it fix any
existing bugs.  Although I might do bug fixing in a later patch, I wanted to keep this as
a pure "code readability" patch.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message