lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Hahn (JIRA)" <j...@apache.org>
Subject [jira] [Created] (SOLR-4729) Using a copyField with * as the source doesn't work
Date Wed, 17 Apr 2013 16:47:16 GMT
Adam Hahn created SOLR-4729:
-------------------------------

             Summary: Using a copyField with * as the source doesn't work
                 Key: SOLR-4729
                 URL: https://issues.apache.org/jira/browse/SOLR-4729
             Project: Solr
          Issue Type: Bug
          Components: Schema and Analysis
    Affects Versions: 4.2
            Reporter: Adam Hahn


It seems you can no longer use a wildcard as the source when defining a copyField.  I don't
believe that this was fixed as part of SOLR-4650 since I've tested it with the 4/17 nightly
build and it doesn't work.

I'm using the following line: <copyField source="*" dest="text"/>

If I index something, this line is ignored.  If I go to the Analysis tab, the fields aren't
populated and I see the error: 'org.apache.solr.common.SolrException: undefined field: "*"'
in the log.

This worked correctly in 4.0, but I didn't test it in 4.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message