lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SOLR-1905) Multicore admin/cores?action=CREATE
Date Wed, 10 Apr 2013 03:06:16 GMT

     [ https://issues.apache.org/jira/browse/SOLR-1905?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Erick Erickson resolved SOLR-1905.
----------------------------------

       Resolution: Fixed
    Fix Version/s: 5.0
                   4.3

Fixed in SOLR-4663
                
> Multicore admin/cores?action=CREATE 
> ------------------------------------
>
>                 Key: SOLR-1905
>                 URL: https://issues.apache.org/jira/browse/SOLR-1905
>             Project: Solr
>          Issue Type: Bug
>          Components: multicore
>    Affects Versions: 1.4
>         Environment: Solaris x86, jdk 1.6, tomcat 2.0.16
>            Reporter: Robbin Turner
>            Assignee: Erick Erickson
>             Fix For: 4.3, 5.0
>
>
> Using the information off the CoreAdmin Wiki,  I initially set up Solr with one core
with solr.xml looking like the following:
> <solr persistent="true" sharedLib="lib">
>                 <cores adminPath="/admin/cores" sharedSchema="false">
>                                 <core name="core1" instanceDir="/opt/solrcores"
>                                                 dataDir="/data1/core1"
>                                                 config="solrconfig.xml"
>                                                 properties="conf/solrcore-core1.properties"
>                                                 schema="schema-core1.xml" />
>                 </cores>
> </solr>
> The application starts up fine and I can get to the http://<solrhost:port>/solrcores.
 I see the link for Admin core1 and everything is running fine.  I then enter the URL:
> http://<solrhost:port>/solrcores/admin/cores?action=CREATE&name=core2&instanceDir=/opt/solrcores&config=solrconfig-core2.xml&schema=schema-core2.xml&dataDir=/data1/core2&properties=conf/solrcore-core2.properties
> to create my next core, core2.  The new core is registered and does show in the base
URL, http://<solrhost:port>/solrcores, which now list links for Admin core1 and Admin
core2.
> When I looked in the solr.xml, I see the following:
> <solr persistent="true" sharedLib="lib">
>                 <cores adminPath="/admin/cores" sharedSchema="false">
>                                 <core name="core1" instanceDir="/opt/solrcores" schema="schema-core1.xml"
properties="conf/solrcore-core1.properties" dataDir="/data1/core1" />
>                                 <core name="core2" instanceDir="/opt/solrcores" schema="schema-core2.xml"
dataDir="/data1/core2"  />
>                 </cores>
> </solr>
> Shouldn't all the parameters be added to the solr.xml core2 that were passed in from
the URL?  And why did the config="solrconfig.xml" get removed from the core1 definition?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message