lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Høydahl (JIRA) <>
Subject [jira] [Updated] (SOLR-3613) Namespace Solr's JAVA OPTIONS
Date Tue, 19 Mar 2013 22:23:17 GMT


Jan Høydahl updated SOLR-3613:

    Attachment: SOLR-3613.patch

Dumping old un-finished patch for revision 1388725 (September 2012) in here, just to record
the work I started. Perhaps something can be used for SOLR-4615
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>                 Key: SOLR-3613
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0-ALPHA
>            Reporter: Jan Høydahl
>             Fix For: 4.3
>         Attachments: SOLR-3613.patch
> Solr being a web-app, should play nicely in a setting where users deploy it on a shared
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid name clashes
and for clarity when reading your appserver startup script. We currently do that with most:
{{solr.solr.home,, solr.abortOnConfigurationError, solr.directoryFactory, solr.clustering.enabled,
solr.velocity.enabled etc}}, but for some opts we fail to do so.
> Before release of 4.0 we should make sure to clean this up.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message