lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-4462) SolrJ's httpclient and httpcore dependency versions should not be synchronized - instead, the httpcore version to use should be drawn from the httpclient POM
Date Fri, 15 Feb 2013 18:13:13 GMT

    [ https://issues.apache.org/jira/browse/SOLR-4462?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13579373#comment-13579373
] 

Hoss Man commented on SOLR-4462:
--------------------------------

bq. Comments added to solrj/ivy.xml discussing how to choose versions for httpcomponents httpmime
and httpcore, based on the httpclient version.

+1 ... i actually noticed the discrepency in versions in that ivy.xml file when i commited
r1445945 in SOLR-4451, but thought that was an existing bug (particularly since the pom.xml.template
had a single consistent version number for httpcomponents.version (i didn't realize it was
because of a transitive dependency quirks)

Running tests now with sarowe's patch to sanity check
                
> SolrJ's httpclient and httpcore dependency versions should not be synchronized - instead,
the httpcore version to use should be drawn from the httpclient POM
> -------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: SOLR-4462
>                 URL: https://issues.apache.org/jira/browse/SOLR-4462
>             Project: Solr
>          Issue Type: Bug
>          Components: clients - java
>    Affects Versions: 4.0, 4.1
>            Reporter: Steve Rowe
>            Priority: Minor
>         Attachments: SOLR-4462.patch
>
>
> The httpcomponents project, which hosts both the httpclient and the httpcore modules,
uses Maven as its build system, so when the httpclient POM declares a dependency, it's authoritative
(since that's how httpclient is built and tested).  httpclient depends on httpcore, so the
SolrJ httpcore version should be drawn from the httpclient POM.
> httpclient's httpcore dependency version doesn't always match the httpclient version.
 Recent examples (look for {{<httpcore.version>}} under {{<properties>}}):
> [https://svn.apache.org/repos/asf/httpcomponents/httpclient/tags/4.2.3/pom.xml]
> [http://svn.apache.org/repos/asf/httpcomponents/httpclient/tags/4.1.3/pom.xml]
> [http://svn.apache.org/repos/asf/httpcomponents/httpclient/tags/4.1.1/pom.xml]
> I'm fairly certain that these versions-out-of-sync incidents are not mistakes - I read
this email exchange as describing intentionally versioning httpclient separately from httpcore:
[http://markmail.org/thread/ippp4gbxwwnt6aws].
> SolrJ should separately version its httpclient and httpcore dependencies, and should
draw the httpcore version from the httpclient POM.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message