lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Alkema (JIRA)" <j...@apache.org>
Subject [jira] [Issue Comment Deleted] (SOLR-3876) Solr Admin UI is completely dysfunctional on IE 9
Date Wed, 02 Jan 2013 19:00:13 GMT

     [ https://issues.apache.org/jira/browse/SOLR-3876?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Paul Alkema updated SOLR-3876:
------------------------------

    Comment: was deleted

(was: I HATE IE with a passion. I think most coders will agree that chrome and Firefox are
just much better browsers. But the issue I have, is that windows server's come with IE installed
and any good server administrator is not going to allow 3rd party browsers to be installed
on a production server. Because of this the only way that you can use the solr admin is by
opening up the admin to the public. From what I've seen, solr doesn't have any types of security
logins built into it, so opening this up to the public creates a serious security issue. 

My personal solution to this problem was to change my firewall settings to open up the solr
port only to my IP but many people won't do this and honestly I think it's pretty lame that
Solr's documentation says that it supports Windows but yet doesn't support the default windows
browser. Agreed?)
    
> Solr Admin UI is completely dysfunctional on IE 9
> -------------------------------------------------
>
>                 Key: SOLR-3876
>                 URL: https://issues.apache.org/jira/browse/SOLR-3876
>             Project: Solr
>          Issue Type: Bug
>          Components: web gui
>    Affects Versions: 4.0-BETA, 4.0
>         Environment: Windows 7, IE 9
>            Reporter: Jack Krupansky
>            Priority: Critical
>             Fix For: 4.2, 5.0
>
>         Attachments: screenshot-1.jpg, screenshot-2.jpg, screenshot-3.jpg
>
>
> The Solr Admin UI is completely dysfunctional on IE 9. See attached screen shot. I don't
even see a "collection1" button. But Admin UI is working fine in Google Chrome with same running
instance of Solr.
> Currently running 4.0 RC0, but problem existed with 4.0-BETA.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message