lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stanislaw Osinski (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SOLR-3279) Upgrade Carrot2 to minimize the possibility of dependency clashes
Date Wed, 02 Jan 2013 12:16:12 GMT

     [ https://issues.apache.org/jira/browse/SOLR-3279?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stanislaw Osinski resolved SOLR-3279.
-------------------------------------

    Resolution: Fixed

Carrot2 upgraded to 3.6.2 in trunk and 4.x branch.

NB: Carrot2 3.6.2 stock binaries ship with Guava r12, but r13 (currently in Solr) is backwards
compatible. If at some point upgrade to r14 is needed, it will most likely be possible without
upgrading Carrot2.
                
> Upgrade Carrot2 to minimize the possibility of dependency clashes
> -----------------------------------------------------------------
>
>                 Key: SOLR-3279
>                 URL: https://issues.apache.org/jira/browse/SOLR-3279
>             Project: Solr
>          Issue Type: Task
>          Components: contrib - Clustering
>            Reporter: Stanislaw Osinski
>            Assignee: Stanislaw Osinski
>            Priority: Minor
>             Fix For: 4.1
>
>
> When we get closer to the 4.0 release, update Carrot2 to the then newest version so that
the dependencies get a refresh too (re: http://lucene.472066.n3.nabble.com/Old-Google-Guava-library-needs-updating-r05-td3854433.html).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message