lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Commit Tag Bot (JIRA)" <>
Subject [jira] [Commented] (SOLR-4229) "Swappable" (introduced in 1028) is confusing. Change the name
Date Sat, 29 Dec 2012 21:12:12 GMT


Commit Tag Bot commented on SOLR-4229:

[branch_4x commit] Erick Erickson

merge to 4x of SOLR-4229 (rename swappable to transient for cores that can come and go)

> "Swappable" (introduced in 1028) is confusing. Change the name
> --------------------------------------------------------------
>                 Key: SOLR-4229
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>            Reporter: Erick Erickson
>            Assignee: Erick Erickson
>            Priority: Blocker
>             Fix For: 4.1, 5.0
>         Attachments: SOLR-4229.patch
> the new tag "swappable", introduced in SOLR-1028 is too easily confused with swapping
cores. Rename to "dynamic"? "transient"? I think "transient" captures the notion best.
> Marking "blocker" just because I want to insure it's changed before the whole notion
is released the first time, patch real soon now. I think we can justify changing the names
of things like this more easily before it's in "official" circulation.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message