lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Smiley, David W." <dsmi...@mitre.org>
Subject Re: Spatial4j dependency in lucene 4.0.0, final
Date Thu, 15 Nov 2012 21:05:02 GMT
Hi Karl!

You say that the dependency isn't versioned, but all dependencies are versioned.  If you say
it's unversioned because you can't see the version in the pom for lucene-spatial, that's because
it's specified in the <dependencyManagement> section of the parent pom for lucene itself.
 Lucene 4.0.0-BETA depends on Spatial4j 0.2, and Lucene 4.0.0 depends on Spatial4j 0.3.  I'm
not sure what to say about your code that won't compile with either.

By the way, if you would like to participate in shaping Spatial4j and/or Lucene spatial, then
I welcome your input; I know you have some spatial experience with MetaCarta.  Presently,
it's basically just me + a little bit of Chris Male; Ryan McKinley has 0 bandwidth these days.

Cheers,
David

On Nov 15, 2012, at 10:27 AM, <karl.wright@nokia.com<mailto:karl.wright@nokia.com>>
 <karl.wright@nokia.com<mailto:karl.wright@nokia.com>> wrote:

Hi guys,

The 4.0.0 lucene-spatial maven dependency on spatial4j is UNVERSIONED.  But the two spatial4j
versions in play (0.2 and 0.3) are significantly different.  We have code developed for lucene-spatial
4.0.0 beta which doesn’t seem to compile with either spatial4j version.  What was the intention
here?

Karl



Mime
View raw message