lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <>
Subject Re: IndexWriter.ensureOpen and ensureOpen(boolean)
Date Fri, 30 Nov 2012 13:29:02 GMT
On Fri, Nov 30, 2012 at 7:13 AM, Shai Erera <> wrote:
> I see. So two questions:
> 1) Is it ok for prepareCommit() to call ensureOpen(false)? In LUCENE-4575 I
> consolidate the two prepCommit() and this is the only way it would work ...

Hmm prepareCommit() really should somehow pass true: this API is only
invoked by the app, not by IW internally during close.  Not sure how
we can fix the patch to get that back ...

> 2) Could you perhaps clarify the use of the second argument in the javadocs?
> Maybe also rename it to something like "fail if closing"? The name
> "includePendingClose" is vague perhaps consider*?)

I agree that current name is no good!  failIfClosing seems good?

Mike McCandless

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message