lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4399) Rename AppendingCodec to Appending40Codec
Date Thu, 04 Oct 2012 20:53:48 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13469680#comment-13469680
] 

Robert Muir commented on LUCENE-4399:
-------------------------------------

We dont force them to be the same. But to date they have been, and its currently still the
case, so i check it.

 in the future its possible we might need to bump something about just the terms index file
or whatever.
                
> Rename AppendingCodec to Appending40Codec
> -----------------------------------------
>
>                 Key: LUCENE-4399
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4399
>             Project: Lucene - Core
>          Issue Type: New Feature
>            Reporter: Adrien Grand
>            Assignee: Adrien Grand
>            Priority: Minor
>             Fix For: 4.1
>
>         Attachments: LUCENE-4399.patch, LUCENE-4399.patch, LUCENE-4399.patch
>
>
> In order AppendingCodec to follow Lucene codecs version, I think its name should include
a version number (so that, for example, if we get to releave Lucene 4.3 with a new Lucene43Codec,
there will also be a new Appending43Codec).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message