lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erick Erickson (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (SOLR-4011) SolrCore - correct behavior while having error loading specific cores
Date Mon, 29 Oct 2012 14:20:13 GMT

     [ https://issues.apache.org/jira/browse/SOLR-4011?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Erick Erickson resolved SOLR-4011.
----------------------------------

    Resolution: Not A Problem

Gian:

No Problem, I'll close this and we can re-open it if there's something that should be done
Solr-wise....
                
> SolrCore - correct behavior while having error loading specific cores
> ---------------------------------------------------------------------
>
>                 Key: SOLR-4011
>                 URL: https://issues.apache.org/jira/browse/SOLR-4011
>             Project: Solr
>          Issue Type: Improvement
>          Components: multicore
>         Environment: RHEL 6.1/6.3
> Solr 3.6.1
>            Reporter: Gianluca Varisco
>            Assignee: Erick Erickson
>            Priority: Minor
>
> I've a multicore setup.  Solr.xml contains the following:
> <solr persistent="false">
>   <!--
>   adminPath: RequestHandler path to manage cores.  
>     If 'null' (or absent), cores will not be manageable via request handler
>   -->
> <cores adminPath="/admin/cores">
> <core name="a" instanceDir="/shop/www/htdocs/a/shop.staging/solr/app" dataDir="/shop/solr/staging/a/data/"
configName="solrconfig.xml" schemaName="schema.xml" />
> <core name="b" instanceDir="/shop/www/htdocs/b/shop.staging/solr/app" dataDir="/shop/solr/staging/b/data/"
configName="solrconfig.xml" schemaName="schema.xml" />
> <core name="c" instanceDir="/shop/www/htdocs/c/shop.staging/solr/app" dataDir="/shop/solr/staging/c/data/"
configName="solrconfig.xml" schemaName="schema.xml" />
> </cores>
> </solr>
> When solr starts, it tries to LOAD all the cores. If one fails (no solrconfig.xml or
instanceDir found), the whole multicore configuration is broken and Solr won't answer as well
for the other two cores. 
> Is there a workaround for it? Reasons while it can happen is, for example, if cores'
creation in the XML are managed indipendently (e.g via Puppet) but applications are not deployed
in that instanceDir yet (therefore: no solrconfig.xml/schema.xml). Is there a specific parameter
to use?
>  

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message