lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4399) Rename AppendingCodec to Appending40Codec
Date Thu, 04 Oct 2012 21:09:47 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13469700#comment-13469700
] 

Robert Muir commented on LUCENE-4399:
-------------------------------------

I dont its a goal to check that they are really consistent? Really we can remove this check.

I think every file should have its own name and version number. If XYZ writer has 10 files,
then 
it should have 10 independent codec names and version numbers.

This was a bug in this stuff before (LUCENE-3621).

For the stored fields writer i'm not pedantic enough to go fix the fact it shares version
numbers,
but I'm just saying we really have to always look at this conceptually as a per-file thing.

Otherwise we defeat a lot of the purpose of having a codec header at all (verifying this file
really
is what you think it is, and the version you think it is). 

                
> Rename AppendingCodec to Appending40Codec
> -----------------------------------------
>
>                 Key: LUCENE-4399
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4399
>             Project: Lucene - Core
>          Issue Type: New Feature
>            Reporter: Adrien Grand
>            Assignee: Adrien Grand
>            Priority: Minor
>             Fix For: 4.1
>
>         Attachments: LUCENE-4399.patch, LUCENE-4399.patch, LUCENE-4399.patch
>
>
> In order AppendingCodec to follow Lucene codecs version, I think its name should include
a version number (so that, for example, if we get to releave Lucene 4.3 with a new Lucene43Codec,
there will also be a new Appending43Codec).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message