lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: clover report incomplete?
Date Fri, 28 Sep 2012 10:02:37 GMT
Thanks: thats crazy. I was totally baffled, looking through all the files.

But it drove me crazy because codecs/build.xml was so simple and i
couldn't see any other obvious special cases for it.

I will never know how you found this!

On Fri, Sep 28, 2012 at 4:31 AM, Uwe Schindler <uwe@thetaphi.de> wrote:
> Hi Robert,
>
> A very stupid problem, but after a long time sitting in fornt of the build.xml I found
it:
>
> 1. The biggest problem was: the target "clover" was made in a way that it used the clover.loaded
sysprop to avoid permgen issues. Unfortunatley it not only loaded clover, it also set it up
in this task (setting the java source file folders). If the taskdef was then loaded for the
first time, it had its source folders set up with the module it was called first. The later
coming compilation of another module did not run clover.setup anymore, so no new source folders
were configured. I split up the IVY-Load+Taskdef from the clover setup
>
> 2. test-framework had a strange comment that it should not depend on clover, which I
removed. This was done to disable instrumentation for test-framework at all. I fixed this
to make the test-framework's sources to be "defined" as "test-sources" not application class,
so clover is enabled but it's now handled as tests (this was done by redefinition of -clover.setup
task in test-framework). Same for Solr.
>
> I will play around a little longer and then commit.
>
> -----
> Uwe Schindler
> H.-H.-Meier-Allee 63, D-28213 Bremen
> http://www.thetaphi.de
> eMail: uwe@thetaphi.de
>
>
>> -----Original Message-----
>> From: Robert Muir [mailto:rcmuir@gmail.com]
>> Sent: Friday, September 28, 2012 2:50 AM
>> To: dev@lucene.apache.org
>> Subject: clover report incomplete?
>>
>> https://builds.apache.org/job/Lucene-Solr-Clover-4.x/clover/pkg-summary.html
>>
>> doesn't seem to include any of the packages in codecs/ module (e.g.
>> appending, block, ...)
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org For additional
>> commands, e-mail: dev-help@lucene.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message