lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: Is it safe to upgrade to Oracle Java 7u7 for Lucene/Solr development and use?
Date Thu, 20 Sep 2012 15:45:06 GMT
BUILD.txt:

Lucene Build Instructions

Basic steps:
  0) Install JDK 1.6 (or greater)

On Thu, Sep 20, 2012 at 11:40 AM, Jack Krupansky
<jack@basetechnology.com> wrote:
> Okay, that was the one place I hadn’t looked. Thanks. Still, it seems to me
> that a release should clearly state what it requires, and there is no
> mention in the 4.0 text files what Java versions are supported, other than
> the ambiguous references I mentioned. I mean, if someone is starting out
> with 4.0, why should they have to read the release notes for 3.6??
>
> -- Jack Krupansky
>
> From: Uwe Schindler
> Sent: Thursday, September 20, 2012 10:52 AM
> To: dev@lucene.apache.org
> Subject: RE: Is it safe to upgrade to Oracle Java 7u7 for Lucene/Solr
> development and use?
>
>
> We already stated that in Lucene 3.5/3.6 release note! It’s fine since Java
> 7u1. There are no news in Lucene 4.0
>
>
>
> -----
>
> Uwe Schindler
>
> H.-H.-Meier-Allee 63, D-28213 Bremen
>
> http://www.thetaphi.de
>
> eMail: uwe@thetaphi.de
>
>
>
> From: Jack Krupansky [mailto:jack@basetechnology.com]
> Sent: Thursday, September 20, 2012 4:49 PM
> To: Lucene/Solr Dev
> Subject: Is it safe to upgrade to Oracle Java 7u7 for Lucene/Solr
> development and use?
>
>
>
> The Oracle Java Update tool on my Windows PC is pretty insistent that it
> wants to update my machine to Java 7u7 and REMOVE Java 6. Is it safe to use
> Java 7u7 for both Lucene Solr development and running Solr yet? My
> presumption has been that Lucene/Solr still “requires” Java 6.
>
>
>
> The 4.0 Solr README.txt says to use the Java 6 JDK, but then adds “verify
>
> that the Java version is 1.6 or later ”, implying that a later release would
> be okay. Given that Java 7 will be the “current” release, the README should
> make some specific statement regarding Java 7.
>
>
>
> And maybe the top-level README.txt should have a Java version statement –
> unless both 7 and 6 are fine – although there is a minimum update level that
> works for 7 and Lucene, right? In any case, clear guidance should be
> provided.
>
>
>
> The Solr 4.0 CHANGES.txt does say “You
>
> need a Java 1.6 VM or later installed”, suggesting that Java 7 is fine. No
> mention of Java version requirement in the Lucene CHANGES.txt.
>
>
>
> I may just manually install 7u7 and not use it to avoid the update notice
> until Lucene/Solr “upgrades” to Java 7, but I suspect a fair number of
> people will simply take the update and say goodbye to Java 6.
>
>
> -- Jack Krupansky



-- 
lucidworks.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message