lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject "ant precommit" can't find python
Date Tue, 18 Sep 2012 11:30:49 GMT
I tried running "ant precommit" on my machine and get this after it
cranks away for a while:


/Users/Erick/apache/4x/build.xml:59: The following error occurred
while executing this line:
/Users/Erick/apache/4x/lucene/build.xml:230: The following error
occurred while executing this line:
/Users/Erick/apache/4x/lucene/common-build.xml:1802: Execute failed:
java.io.IOException: Cannot run program "python3.2" (in directory
"/Users/Erick/apache/4x/lucene"): error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
	at java.lang.Runtime.exec(Runtime.java:593)
        .
        .
        .

It appears that I have python 2.6 hanging around on my machine, but
I've never used it, so haven't set up anything, and it's the wrong
version anyway.

Can we add a check for python existing up-front and maybe print a
helpful message (I'm thinking something like ivy-bootstrap)? I'm
guessing that actually having the executable in 4x/lucene isn't the
best solution and I should have an env variable somewhere?

Erick

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message