lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yonik Seeley <yo...@lucidworks.com>
Subject SPI loading failures
Date Sat, 08 Sep 2012 18:43:46 GMT
I'm getting SPI failures running any test in IntelliJ:

Caused by: java.lang.IllegalArgumentException: A SPI class of type
org.apache.lucene.codecs.Codec with name 'SimpleText' does not exist.
You need to add the corresponding JAR file supporting this SPI to your
classpath.The current classpath supports the following names:
[Asserting, Lucene40]
	at org.apache.lucene.util.NamedSPILoader.lookup(NamedSPILoader.java:104)

Is it really the case that an actual JAR file is needed, or can we
load from a simple class in the classpath?

I'll continue to fiddle with it to see if I can make it happy, but
pointers would be welcome.

-Yonik
http://lucidworks.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message