lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (JIRA)" <>
Subject [jira] [Commented] (SOLR-3488) Create a Collections API for SolrCloud
Date Fri, 14 Sep 2012 21:40:08 GMT


Yonik Seeley commented on SOLR-3488:

bq. but create the collection with a replication factor of 5,

Which reminds me... is "replicationFactor" a better name than "numReplicas" that we have now?
 If so we should change at the same time we make the changes for the slice properties.  It
seems like replicationFactor better expresses that it's a target and not the actual number
of replicas.  This will also make things less confusing when we allow the replication factor
to be overridden on a per-shard basis.  Imagine seeing "numReplicas=3" as a shard property
but then seeing only one replica listed under that shard!

> Create a Collections API for SolrCloud
> --------------------------------------
>                 Key: SOLR-3488
>                 URL:
>             Project: Solr
>          Issue Type: New Feature
>          Components: SolrCloud
>            Reporter: Mark Miller
>            Assignee: Mark Miller
>             Fix For: 4.0
>         Attachments: SOLR-3488_2.patch, SOLR-3488.patch, SOLR-3488.patch, SOLR-3488.patch

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message