lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David Smiley (JIRA)" <>
Subject [jira] [Resolved] (LUCENE-4374) Spatial- rename vector.TwoDoublesStrategy to vector.PointVectorStrategy
Date Sat, 22 Sep 2012 21:55:07 GMT


David Smiley resolved LUCENE-4374.

       Resolution: Fixed
    Fix Version/s:     (was: 4.1)

There was one breaking problem of pointVector instead of pointVector in the patch I fixed.

Committed to trunk, 4x, and 4.0 branches.
> Spatial- rename vector.TwoDoublesStrategy to vector.PointVectorStrategy
> -----------------------------------------------------------------------
>                 Key: LUCENE-4374
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: modules/spatial
>            Reporter: David Smiley
>            Assignee: David Smiley
>             Fix For: 4.0
>         Attachments: LUCENE-4374_Rename_TwoDoubles_to_PointVector.patch
> TwoDoubles isn't necessarily appropriate since it could be two floats, once it is enhanced
to make that configurable.  I like PointVector because it's clear it indexes points.  Eventually
I could imagine a CircleVectorStrategy in the same package.
> This does suggest BBoxStrategy should be RectVectorStrategy in the vector package.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message