lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4371) consider refactoring slicer to indexinput.slice
Date Mon, 10 Sep 2012 17:35:07 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4371?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13452166#comment-13452166
] 

Uwe Schindler commented on LUCENE-4371:
---------------------------------------

+1 to rermove the slicer! I was thinking about that the whole time and it really makes it
easier.

In general for 4.0, we should make the slice method abstract and *not* provide a default implementation.
In most cases its as easy to implement like clone().
                
> consider refactoring slicer to indexinput.slice
> -----------------------------------------------
>
>                 Key: LUCENE-4371
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4371
>             Project: Lucene - Core
>          Issue Type: Task
>            Reporter: Robert Muir
>         Attachments: LUCENE-4371.patch
>
>
> From LUCENE-4364:
> {quote}
> In my opinion, we should maybe check, if we can remove the whole Slicer in all Indexinputs?
Just make the slice(...) method return the current BufferedIndexInput-based one. This could
be another issue, once this is in.
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message