lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] [Commented] (LUCENE-4369) StringFields name is unintuitive and not helpful
Date Tue, 11 Sep 2012 11:56:09 GMT


Uwe Schindler commented on LUCENE-4369:

The names "ExactMatchField" or "MatchOnlyField" both have the problem, that they only refer
to the indexing side. I would be fine with that name, if it would be "unstored" by default,
so you have to turn on storing explicit. If it is automatically stored, people will complain
that their index has too many useless garbage, because they expected a ExactMatchField to
be used only for "matching", so "storing" is wrong.

I would prefer: UntokenizedField or UntokenizedStringField
> StringFields name is unintuitive and not helpful
> ------------------------------------------------
>                 Key: LUCENE-4369
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-4369.patch
> There's a huge difference between TextField and StringField, StringField screws up scoring
and bypasses your Analyzer.
> (see java-user thread "Custom Analyzer Not Called When Indexing" as an example.)
> The name we use here is vital, otherwise people will get bad results.
> I think we should rename StringField to MatchOnlyField.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message