lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adrien Grand (JIRA)" <>
Subject [jira] [Commented] (SOLR-3830) Rename LFUCache to FastLFUCache
Date Wed, 12 Sep 2012 19:50:07 GMT


Adrien Grand commented on SOLR-3830:

bq. we should not be adding new names with "Fast" in front of them

This is why I also suggested to rename FastLRUCache to ConcurrentLRUCache in my 2nd paragraph
(or something else, I'm open to other ideas).

bq. OK, let's leave things as they are then. Documentation is the key if we need to clarify

Why don't you like renaming FastLRUCache to something else and adding a deprecated FastLRUCache
subclass for backward compatibility, as Chris suggests?
> Rename LFUCache to FastLFUCache
> -------------------------------
>                 Key: SOLR-3830
>                 URL:
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.0-BETA
>            Reporter: Adrien Grand
>            Priority: Minor
> I find it a little disturbing that LFUCache shares most of its behavior (not strictly
bounded size, good at concurrent reads, slow at writes unless eviction is performed in a separate
thread) with FastLRUCache while it sounds like it is the LFU equivalent of LRUCache (strictly
bounded size, synchronized reads, fast writes) so I'd like to rename it to FastLFUCache.
> Maybe we should also rename these Fast*Cache to Concurrent*Cache so that people don't
think that they are better than their non Fast alternatives in every way.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message