lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <>
Subject [jira] [Commented] (LUCENE-4369) StringFields name is unintuitive and not helpful
Date Tue, 11 Sep 2012 11:48:07 GMT


Uwe Schindler commented on LUCENE-4369:

bq. We don't need to rush it, I think its fairly contained to change, we don't even have to
deal with this for 
4.0 if we aren't happy: we can deprecate StringField just have it extend XXXField in a future
4.x release too.

I am against this, we should change this before Lucene 4.0. We have seen already on user list
that many people understand it wrong, so for me this issue is a "Blocker" for 4.0.
> StringFields name is unintuitive and not helpful
> ------------------------------------------------
>                 Key: LUCENE-4369
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-4369.patch
> There's a huge difference between TextField and StringField, StringField screws up scoring
and bypasses your Analyzer.
> (see java-user thread "Custom Analyzer Not Called When Indexing" as an example.)
> The name we use here is vital, otherwise people will get bad results.
> I think we should rename StringField to MatchOnlyField.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message