lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <>
Subject [jira] [Commented] (LUCENE-4369) StringFields name is unintuitive and not helpful
Date Wed, 12 Sep 2012 18:23:07 GMT


Hoss Man commented on LUCENE-4369:

Didn't we spcifically get rid of an enums called TOKENIZED and UN_TOKENIZED because they convoluted
the concept of tokenization with analysis?  weren't there users who wanted "keyword" tokenization
combined with other tokenfilters who thought UN_TOKENIZED was what they wanted?

Perhaps TextField should be renamed AnalyzedTextField and StringField should be NonAnalyzedTextField
> StringFields name is unintuitive and not helpful
> ------------------------------------------------
>                 Key: LUCENE-4369
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-4369.patch
> There's a huge difference between TextField and StringField, StringField screws up scoring
and bypasses your Analyzer.
> (see java-user thread "Custom Analyzer Not Called When Indexing" as an example.)
> The name we use here is vital, otherwise people will get bad results.
> I think we should rename StringField to MatchOnlyField.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message