lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4439) IOUtils.copy stops copying when InputStream.read returns 0
Date Wed, 26 Sep 2012 14:21:07 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4439?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13463848#comment-13463848
] 

Uwe Schindler commented on LUCENE-4439:
---------------------------------------

I agree, see my changed comment! :-)

I would still prefer to check for >=0 instead >0 in this case. But we know here that
the buffer is 8 KB (its allocated in the line before).
                
> IOUtils.copy stops copying when InputStream.read returns 0
> ----------------------------------------------------------
>
>                 Key: LUCENE-4439
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4439
>             Project: Lucene - Core
>          Issue Type: Bug
>    Affects Versions: 4.0
>            Reporter: Adrien Grand
>            Priority: Minor
>             Fix For: 4.1, 5.0
>
>
> IOUtils.copy has the following lines of code:
> {noformat}
>       while ((len = fis.read(buffer)) > 0) {
>         fos.write(buffer, 0, len);
>       }
> {noformat}
> The problem is that the fact that {{InputStream.read}} returns 0 does not mean that it
reached the end of the stream (there is -1 for this), so this method might not copy the whole
file in rare cases.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message