lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <>
Subject [jira] [Commented] (LUCENE-4369) StringFields name is unintuitive and not helpful
Date Tue, 11 Sep 2012 11:10:08 GMT


Shai Erera commented on LUCENE-4369:

bq. So how about "ExactMatchField"?

+1 for that. I was actually going to propose "MatchExactField", but I don't mind the order
of the words.

Also, since a way to search for these terms/fields using the regular query syntax would be
through a PerFieldAnalyzerWrapper and assigning KeywordAnalyzer to that field (are there other
ways), we can also call it KeywordField.

I don't like MatchOnlyField .. i.e. TextField also matches *only* the words that are indexed
in that field.
> StringFields name is unintuitive and not helpful
> ------------------------------------------------
>                 Key: LUCENE-4369
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-4369.patch
> There's a huge difference between TextField and StringField, StringField screws up scoring
and bypasses your Analyzer.
> (see java-user thread "Custom Analyzer Not Called When Indexing" as an example.)
> The name we use here is vital, otherwise people will get bad results.
> I think we should rename StringField to MatchOnlyField.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message