lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4369) StringFields name is unintuitive and not helpful
Date Tue, 11 Sep 2012 11:34:08 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4369?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13452933#comment-13452933
] 

Uwe Schindler commented on LUCENE-4369:
---------------------------------------

ExactMatchField sounds ok, but I don't really like it. On the other hand, we already had Field.KEYWORD(...)
static factory in Lucene 1.x (amybe also early 2.x), and that was always fine to me. The term
Keyword is only misleading (for my german, library background - "Schlagwörter" in GER) to
me, so I would like to have a good term that tells the user "this is a field thats taken as-is).
In general I also dont really like the name KeywordTokenizer or KeywordAnalyzer, too, but
thats given since long time - so coming from this name, KeywordTokenizer -> KeywordField
might be a good idea (like NumericTokenStream -> NumericField), but

The problem with ExactMatch field is: If it is also stored, the name is misleasing again,
so KeywordField is better. If we would 100% differentiate between stored and indexed fields
while indexing (requiring that the field is also added 2 times, one time as indexed and one
time as indexed), I would be fine with "MatchOnlyField" and "StoredStringField".
                
> StringFields name is unintuitive and not helpful
> ------------------------------------------------
>
>                 Key: LUCENE-4369
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4369
>             Project: Lucene - Core
>          Issue Type: Bug
>            Reporter: Robert Muir
>         Attachments: LUCENE-4369.patch
>
>
> There's a huge difference between TextField and StringField, StringField screws up scoring
and bypasses your Analyzer.
> (see java-user thread "Custom Analyzer Not Called When Indexing" as an example.)
> The name we use here is vital, otherwise people will get bad results.
> I think we should rename StringField to MatchOnlyField.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message