lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yonik Seeley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3830) Rename LFUCache to FastLFUCache
Date Wed, 12 Sep 2012 17:38:07 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3830?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454154#comment-13454154
] 

Yonik Seeley commented on SOLR-3830:
------------------------------------

OK, let's leave things as they are then.  Documentation is the key if we need to clarify anything.
                
> Rename LFUCache to FastLFUCache
> -------------------------------
>
>                 Key: SOLR-3830
>                 URL: https://issues.apache.org/jira/browse/SOLR-3830
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.0-BETA
>            Reporter: Adrien Grand
>            Priority: Minor
>
> I find it a little disturbing that LFUCache shares most of its behavior (not strictly
bounded size, good at concurrent reads, slow at writes unless eviction is performed in a separate
thread) with FastLRUCache while it sounds like it is the LFU equivalent of LRUCache (strictly
bounded size, synchronized reads, fast writes) so I'd like to rename it to FastLFUCache.
> Maybe we should also rename these Fast*Cache to Concurrent*Cache so that people don't
think that they are better than their non Fast alternatives in every way.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message