lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Rowe (JIRA)" <>
Subject [jira] [Commented] (LUCENE-3564) rename IndexWriter.rollback to .rollbackAndClose
Date Tue, 18 Sep 2012 16:58:07 GMT


Steven Rowe commented on LUCENE-3564:

bq. I guess it's OK to leave rollback as "short but misleading"; it's a
fairly expert API. Also, it quickly becomes obvious to the user that
the IW was closed, so it's "fail fast" and the damage is not nearly as
bad as what we see when users don't understand the cost of optimize.

Mike, should this issue be resolved as "won't fix"?
> rename IndexWriter.rollback to .rollbackAndClose
> ------------------------------------------------
>                 Key: LUCENE-3564
>                 URL:
>             Project: Lucene - Core
>          Issue Type: Improvement
>            Reporter: Michael McCandless
>            Assignee: Michael McCandless
>             Fix For: 4.1
> Spinoff from LUCENE-3454, where Shai noticed that rollback is trappy since it [unexpected]
closes the IW.
> I think we should rename it to rollbackAndClose.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message