lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4399) Rename AppendingCodec to Appending40Codec
Date Mon, 17 Sep 2012 15:04:07 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13457070#comment-13457070
] 

Robert Muir commented on LUCENE-4399:
-------------------------------------

I wasn't saying i was totally against the idea btw, i was just trying to invite some discussion...,
just to explain
my rationale:

Personally I dont think its that great we have version numbers in our default codec, I was
the one that proposed this
because its simple on our end as Lucene developers to implement backwards compatibility this
way: but it encourages
some code duplication and stuff like that: which is in my mind, a lesser evil than conditionals
inside one "mega-impl"
like before, that must handle different binary formats.

And i think this is pretty contained to expert users: most people will just create an indexwriter
and be oblivious to this.

As far as alternative things in codecs/, I feel it would be best to not add complication for
back-compat, instead to
try to keep these implementations simple. If we start adding versioning and back compat to
them, then we are basically
expanding our backwards compatibility commitments to N versions * M formats, which is something
that requires a very
big discussion.
                
> Rename AppendingCodec to Appending40Codec
> -----------------------------------------
>
>                 Key: LUCENE-4399
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4399
>             Project: Lucene - Core
>          Issue Type: New Feature
>            Reporter: Adrien Grand
>            Assignee: Adrien Grand
>            Priority: Minor
>             Fix For: 4.0
>
>
> In order AppendingCodec to follow Lucene codecs version, I think its name should include
a version number (so that, for example, if we get to releave Lucene 4.3 with a new Lucene43Codec,
there will also be a new Appending43Codec).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message