lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hoss Man (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SOLR-3830) Rename LFUCache to FastLFUCache
Date Wed, 12 Sep 2012 16:12:07 GMT

    [ https://issues.apache.org/jira/browse/SOLR-3830?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13454085#comment-13454085
] 

Hoss Man commented on SOLR-3830:
--------------------------------

-1.

Repeating my comment from SOLR-3393...

{quote}
#OhDearGodPleaseNotAnotherClassWithFastInTheName

Please, please, please lets end the madness of subjective adjectives in class names ... if
it's an LFU cache wrapped around a "hawtdb" why don't we just call it "HawtDbLFUCache" ?
{quote}

we should not be adding new names with "Fast" in front of them - it does nothing to help the
user understand the value of the class.

{quote}
Maybe we should also rename these Fast*Cache to Concurrent*Cache so that people don't think
that they are better than their non Fast alternatives in every way.
{quote}

I would much rather rename FastLRUCache to something else (with a deprecated FastLRUCache
stub subclass still provided for config backcompat) then see any more a new Fast*Foo class.
                
> Rename LFUCache to FastLFUCache
> -------------------------------
>
>                 Key: SOLR-3830
>                 URL: https://issues.apache.org/jira/browse/SOLR-3830
>             Project: Solr
>          Issue Type: Bug
>    Affects Versions: 4.0-BETA
>            Reporter: Adrien Grand
>            Priority: Minor
>
> I find it a little disturbing that LFUCache shares most of its behavior (not strictly
bounded size, good at concurrent reads, slow at writes unless eviction is performed in a separate
thread) with FastLRUCache while it sounds like it is the LFU equivalent of LRUCache (strictly
bounded size, synchronized reads, fast writes) so I'd like to rename it to FastLFUCache.
> Maybe we should also rename these Fast*Cache to Concurrent*Cache so that people don't
think that they are better than their non Fast alternatives in every way.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message