lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Schindler" <...@thetaphi.de>
Subject RE: Build fail for tests
Date Mon, 03 Sep 2012 08:33:27 GMT
Hi,

 

The problem is that you have an older jUnit version in your $ANT_HOME/lib or ~/.ant/lib classpath.
Please use a freshly and clean installed ANT version (not one from your Linux distribution,
those are often cluttered with outdated stuff). Lucene needs no such libraries like JUnit
in classpath, as it downloads then via IVY automatically and uses it locally. But if there
are old versions already in the classpath, it cannot do anything.

 

Uwe

 

-----

Uwe Schindler

H.-H.-Meier-Allee 63, D-28213 Bremen

http://www.thetaphi.de <http://www.thetaphi.de/> 

eMail: uwe@thetaphi.de

 

From: Sivan Yogev [mailto:sivan.yogev@gmail.com] 
Sent: Monday, September 03, 2012 10:26 AM
To: dev@lucene.apache.org
Subject: Build fail for tests

 

Hi,

I am trying to run the tests for lucene with some modifications, and getting this output:

compile-core:
    [mkdir] Created dir: D:\workspace\lucene-trunk\lucene\build\test-framework\classes\java
    [javac] Compiling 87 source files to D:\workspace\lucene-trunk\lucene\build\test-framework\classes\java
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
     [copy] Copying 3 files to D:\workspace\lucene-trunk\lucene\build\test-framework\classes\java

compile-test:
    [mkdir] Created dir: D:\workspace\lucene-trunk\lucene\build\core\classes\test
    [javac] Compiling 325 source files to D:\workspace\lucene-trunk\lucene\build\core\classes\test
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
     [copy] Copying 29 files to D:\workspace\lucene-trunk\lucene\build\core\classes\test

install-junit4-taskdef:

validate:

test:
    [mkdir] Created dir: D:\workspace\lucene-trunk\lucene\build\core\test

BUILD FAILED
D:\workspace\lucene-trunk\lucene\build.xml:49: The following error occurred while executing
this line:
D:\workspace\lucene-trunk\lucene\common-build.xml:1056: The following error occurred while
executing this line:
D:\workspace\lucene-trunk\lucene\common-build.xml:741: At least JUnit version 4.10 is required
on junit4's taskdef classpath.

Does anyone know what can cause this?

Thanks,
Sivan


Mime
View raw message