lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Muir <rcm...@gmail.com>
Subject Re: remove FieldsEnum?
Date Sun, 12 Aug 2012 01:53:07 GMT
Here's a patch: http://pastebin.com/PQGSgBtT

On Sat, Aug 11, 2012 at 9:29 AM, Michael McCandless
<lucene@mikemccandless.com> wrote:
> +1
>
> Mike McCandless
>
> http://blog.mikemccandless.com
>
>
> On Sat, Aug 11, 2012 at 9:27 AM, Robert Muir <rcmuir@gmail.com> wrote:
>> FieldsEnum seems kinda awkward, can we just have something like
>> Iterable<String> on Fields?
>>
>> so the consuming code i think would be easier.
>>
>> for (String field : fields) {
>>   Terms terms = fields.terms(field);
>>   ...
>> }
>>
>> I don't like that there are two ways to get the terms for a field
>> today, so there is duplicate logic or crazy
>> stuff to handle this Fields.terms(String) versus FieldsEnum.terms()
>>
>> --
>> lucidimagination.com
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
>> For additional commands, e-mail: dev-help@lucene.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>



-- 
lucidworks.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message