lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael McCandless <luc...@mikemccandless.com>
Subject Re: remove FieldsEnum?
Date Sat, 11 Aug 2012 13:29:18 GMT
+1

Mike McCandless

http://blog.mikemccandless.com


On Sat, Aug 11, 2012 at 9:27 AM, Robert Muir <rcmuir@gmail.com> wrote:
> FieldsEnum seems kinda awkward, can we just have something like
> Iterable<String> on Fields?
>
> so the consuming code i think would be easier.
>
> for (String field : fields) {
>   Terms terms = fields.terms(field);
>   ...
> }
>
> I don't like that there are two ways to get the terms for a field
> today, so there is duplicate logic or crazy
> stuff to handle this Fields.terms(String) versus FieldsEnum.terms()
>
> --
> lucidimagination.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
> For additional commands, e-mail: dev-help@lucene.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message