lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shai Erera (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LUCENE-4258) Incremental Field Updates through Stacked Segments
Date Mon, 30 Jul 2012 18:15:35 GMT

    [ https://issues.apache.org/jira/browse/LUCENE-4258?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13425079#comment-13425079
] 

Shai Erera commented on LUCENE-4258:
------------------------------------

bq. BTW, since the new method is to handle multiple fields (as the name suggests), the operation
descriptions should also be in plural: UPDATE_FIELDS and REPLACE_FIELDS.

Ok. I think to not confuse though, we should call it UPDATE_TERMS (not FIELDS). Then someone
can updateFields() twice, once for all the fields which he wants to REPLACE and second for
the fields he just wants to update their terms.

bq. What about merging?

I wrote about it above -- MergePolicy will need to take care of these stacked segments, and
we'll add something like ,merge/expungeFieldUpdates so the app can call it deliberately.

bq. seems like the app should be using doc values instead, and we should (eventually) make
doc values updatable?

I agree we should not UPDATE_TERMS fields that record norms. I'm not sure that every use case
of storing info in the payload today can be translated to using DocValues, so I don't want
to limit things. So, let's start with UPDATE_TERMS taking care of fields that omit norms.
Then, if we handle payload or not for few use cases, can become as an optimization later on.
In the meanwhile, apps will just need to replace the entire field.

Progress, not perfection ! :)
                
> Incremental Field Updates through Stacked Segments
> --------------------------------------------------
>
>                 Key: LUCENE-4258
>                 URL: https://issues.apache.org/jira/browse/LUCENE-4258
>             Project: Lucene - Core
>          Issue Type: Improvement
>          Components: core/index
>            Reporter: Sivan Yogev
>   Original Estimate: 2,520h
>  Remaining Estimate: 2,520h
>
> Shai and I would like to start working on the proposal to Incremental Field Updates outlined
here (http://markmail.org/message/zhrdxxpfk6qvdaex).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


Mime
View raw message