lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Muir (JIRA)" <>
Subject [jira] [Updated] (LUCENE-2191) rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
Date Mon, 16 Jul 2012 01:51:34 GMT


Robert Muir updated LUCENE-2191:

    Fix Version/s:     (was: 4.1)
> rename Tokenizer.reset(Reader) to Tokenizer.setReader(Reader)
> -------------------------------------------------------------
>                 Key: LUCENE-2191
>                 URL:
>             Project: Lucene - Java
>          Issue Type: Improvement
>          Components: modules/analysis
>            Reporter: Robert Muir
>            Priority: Minor
>             Fix For: 4.0, 5.0
>         Attachments: LUCENE-2191.patch, LUCENE-2191.patch
> in TokenStream there is a reset() method, but the method in Tokenizer used to set a new
Reader is called reset(Reader).
> in my opinion this name overloading creates a lot of confusion, and we see things like
reset(Reader) calling reset() even in StandardTokenizer...
> So I think this would be some work to fulfill all the backwards compatibility, but worth
it because when you look at the existing reset(Reader) and reset() code in various tokenizers,
or the javadocs for Tokenizer, its pretty confusing and inconsistent.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message