lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Miller (JIRA)" <>
Subject [jira] [Commented] (SOLR-3613) Namespace Solr's JAVA OPTIONS
Date Wed, 11 Jul 2012 22:27:34 GMT


Mark Miller commented on SOLR-3613:

bq. This issue got way off topic 

Personally, I'm fine with that. The issue itself is small and contained and the discussion
started here because it is related. Moving the discussion was more effort than it's worth
given the simplicity of the issue IMO - tangents happen in JIRA issues all the time. If other
actions or larger discussion lead out of the discussions this issue brought up, sure, take
them to other jiras. Personally I don't think Roberts change merits a jira issue - we don't
generally make them for website changes.

I think there is a fine balance here between discussing the larger issue while at the same
time coming to some agreement on what to do in this particular issue.

> Namespace Solr's JAVA OPTIONS
> -----------------------------
>                 Key: SOLR-3613
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0-ALPHA
>            Reporter: Jan H√łydahl
>             Fix For: 4.0
> Solr being a web-app, should play nicely in a setting where users deploy it on a shared
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid name clashes
and for clarity when reading your appserver startup script. We currently do that with most:
{{solr.solr.home,, solr.abortOnConfigurationError, solr.directoryFactory, solr.clustering.enabled,
solr.velocity.enabled etc}}, but for some opts we fail to do so.
> Before release of 4.0 we should make sure to clean this up.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message