lucene-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Miller (JIRA)" <>
Subject [jira] [Commented] (SOLR-3613) Namespace Solr's JAVA OPTIONS
Date Wed, 11 Jul 2012 21:14:34 GMT


Mark Miller commented on SOLR-3613:

bq. Btw: I'm willing to do some work on this issue, including updating documentation.

Alright, lets do it then.

Adding to my list:
solr.xml default entries - there may only be one, but I would have to check - we expose zkClientTimeout
(and perhaps other things) as system properties using solr.xml substitution. Those should
also by default have solr. prefixes.
> Namespace Solr's JAVA OPTIONS
> -----------------------------
>                 Key: SOLR-3613
>                 URL:
>             Project: Solr
>          Issue Type: Improvement
>    Affects Versions: 4.0-ALPHA
>            Reporter: Jan H√łydahl
>             Fix For: 4.0
> Solr being a web-app, should play nicely in a setting where users deploy it on a shared
> To this regard Solr's JAVA_OPTS should be properly name spaced, both to avoid name clashes
and for clarity when reading your appserver startup script. We currently do that with most:
{{solr.solr.home,, solr.abortOnConfigurationError, solr.directoryFactory, solr.clustering.enabled,
solr.velocity.enabled etc}}, but for some opts we fail to do so.
> Before release of 4.0 we should make sure to clean this up.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message